[WordPress] Не разворачиваются картинки во всплывающем окне

На днях заметил проблему на одном из блогов (точнее заметила девушка, чей этот блог). На нем картинки грузятся с сайта liveinternet, чтобы зря не тратить платного места.

И так, проблема: если картинка расположена на сайте wordpress, то открывается нормально (всплывающее окно), если на другом сайте — открывается сам файл. Если в начале открыть картинку с сайта, то при переключении остальные отображаются в всплывающем окне. Проверял картинки и с других сайтов, например, с Яндекса, но это ничего не изменило.

Стоял плагин Lightbox Plus. Проверил плагины Shutter Reloaded, Auto Thickbox, FancyBox for WordPress, jQuery Colorbox, у всех аналогичная проблема.

Было проверено несколько способов. Я грешил на защиту от копирования, но такая ситуация и с другими сайтами.

Немного покопавшись я нашел решение данной проблемы:

Проблема была в плагине All in One SEO Pack или в Google Analyticator (в обоих есть одинаковых функции по Google Analytics), при использовании «Отслеживание исходящих ссылок», чтобы исправить надо убрать отключить эту опцию.

2 thoughts on “[WordPress] Не разворачиваются картинки во всплывающем окне

  1. Добрый день! Если кто-нибудь знает, помогите, пожалуйста!
    Я на WordPress установил тему «ElegantEstate» и сразу плагин «Fancybox for WordPress», который используется на демо сайте этого шаблона… При создании статьи есть у этой темы дополнительный пункт «Elegant Estate optios» или как-то в этом роде, там есть 9 полей для загрузки фото из библиотеки файлов, первые 8 из которых это эскизы для страницы, где сама статья и комментарии к ней, а последняя девятая используется, как миниатюра для анонса… на демо сайте все эти фото увеличиваются с помощью плагина «Fancybox for WordPress», и при увеличении под фотографией, над ней или на ней отображается атрибут title в качестве подписи… Но это на демо сайте… А на свой я установил есго сразу на чистый шаблон, создал статью засунул туда все эти 8 эскизов… Работает хорошо, увеличивается правильно… Но атрибут title не хочет отображаться… проверил в firebug от Mozilla Firefox и увидел, что в теге !начало тега! a href = “ссылка на фото” title = “тайтл” class=»fancybox» !конец тега! (Пишу раздельно, чтобы отобразить сам тег, а не его значение.)нет самого атрибута title, что он не отобразился (хотя я в библиотеке файлов прописал к этим всем фото все поля: Заголовок, Описание, Подпись и даже атрибут title), проверил в этом же firebug вставил в этот тег title=»подпись…» и сразу появилась подпись (конечно до обновления страницы, т.к. все изменения кода в firebug временные, т.е. до обновления страницы)… Вывод: где-то нужно прописать, что атрибут title должен брать для себя содержимое из одного из полей в библиотеке файлов у этих фото, чтобы он отображался… Но где, в каком файле и как это сделать нужно? Может кто-нибудь знает? Заранее спасибо за помощь!
    Ссылка на мой сайт: http://domokrim.hosting-test.org.ua
    Ссылка на демо сайт: http://www.elegantthemes.com/demo/?theme=ElegantEstate

Добавить комментарий

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.